Ubuntu von usb stick booten

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Hallo :)
Wollte heute auf einer separaten ssd ubuntu installieren. Win 10 hab ich auf einer anderen Platte.
Hab nun die ubuntu 17.04 x64 iso runtergeladen und mittels "linux live usb" auf einen usb stick kopiert. Sollte dann bootfähig sein. Wenn ich dann aber neu starte, und im bios boot menü den stick auswähle, dann startet einfach windows 10 anstatt die ubuntu installation! Muss ich die win10 platte zuerst abklemmen? Kann es daran liegen? Oder wie könnte ich es sonst machen? Hab auch schon einen anderen stick genommen, und auch ein anderes programm ausprobiert um den usb stick bereit zu stellen.
Vor einem jahr bei linux mint hat es ohne probleme geklappt, verstehe nicht was jetzt schief läuft....
Danke
 

Herbboy

Senior Community Officer
Teammitglied
Mitglied seit
22.03.2001
Beiträge
78.662
Reaktionspunkte
5.931
Hast du wirklich DEN Stick zum Booten gewählt, oder einfach nur "USB" ? Bei letzterem kann es sein, dass du nur nen anderen USB-Port probieren musst. Ansonsten aber keine Ahnung, ob das normal ist. Die Win10-PLatte abzustecken sollte doch aber schnell erledigt sein, so dass du das mal testen kannst
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Hast du wirklich DEN Stick zum Booten gewählt, oder einfach nur "USB" ? Bei letzterem kann es sein, dass du nur nen anderen USB-Port probieren musst. Ansonsten aber keine Ahnung, ob das normal ist. Die Win10-PLatte abzustecken sollte doch aber schnell erledigt sein, so dass du das mal testen kannst

Ja, ich hatte auch nur den einen Stick angeschlossen, hab aber auch da alle Möglichkeiten durchprobiert...
Villeicht liegt es am windows bootloader? Werde die win platte mal abstecken
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Ja, ich hatte auch nur den einen Stick angeschlossen, hab aber auch da alle Möglichkeiten durchprobiert...
Villeicht liegt es am windows bootloader? Werde die win platte mal abstecken

Unwahrscheinlich, wenn die Bootreihenfolge stimmt oder Du ihm explizit sagst von dem Stick zu booten, dann kommt er ja gar nicht bis zum Bootloader. Ich denke eher, dass er nicht von dem Stick booten kann und dann konsequenterweise mit der Platte weiter macht.

Aber wenn Du es ausprobieren willst, dann entferne die Platte im BIOS doch einfach aus der Liste der Boot-Devices. Musst deshalb nicht die Platte abziehen. Aber mach wie Du denkst.

Nutzt Du UEFI oder BIOS? Bei Windows doch wahrscheinlich UEFI. Ist der Stick UEFI-fähig?
 
I

i-suffer-rock

Guest
Die Windows-Festplatte abzuklemmen sollte normalerweise nicht notwendig sein. Mir hat es bei solchen Problemen geholfen, den USB Stick zunächst selbst zu formatieren, und zwar in Windows im Format FAT (Standard). Der USB Stick wird dadurch mit dem FAT16 Dateisystem formatiert, welches die höchstmögliche Kompatibilität aufweist. Danach erst lässt man den Stick durch so ein Live USB Tool beschreiben.

In meinem Fall war nämlich das Problem, dass der schon ältere PC beim booten nur USB-Sticks mit eben diesem Dateiformat FAT16 lesen konnte.
 

Batze

Bekanntes Gesicht
Mitglied seit
03.09.2001
Beiträge
15.222
Reaktionspunkte
4.066
Kleiner Tipp, die Windows Platte, alle Platten, sowieso unbedingt abklemmen, sonst knallt dir Linux seinen Bootmanager drauf, und das kann, wenn man nicht mit umgehen kann gehörig in die Hose gehen.
Nach der Linux installation einfach das Bootmenü von deinem Board dann aufrufen, kann momentan jedes Board und dauert nur 1 sekunde mehr, aber du gehst damit so einigen Problemen aus dem Weg.

Eventuell hilft dir mein vor langer Zeit geschriebener Guide für mehrere Betriebssysteme da weiter. KLICK.
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Danke für die antworten :)
An der windows platte lag es tatsächlich nicht. Aber der usb stick macht wohl probleme. Hab mir mit gparted den stick genauer angesehen und da waren allerlei komische partitionen drauf. Hab alle gelöscht so dass jetzt nur mehr eine partition am stick drauf ist + wurde mit fat32 formatiert. Werde es jetzt nochmal versuchen mit linuxblive usb.
Bei der installation werde ich dann ohnehin alle anderen platten abklemmen
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Unwahrscheinlich, wenn die Bootreihenfolge stimmt oder Du ihm explizit sagst von dem Stick zu booten, dann kommt er ja gar nicht bis zum Bootloader. Ich denke eher, dass er nicht von dem Stick booten kann und dann konsequenterweise mit der Platte weiter macht.

Aber wenn Du es ausprobieren willst, dann entferne die Platte im BIOS doch einfach aus der Liste der Boot-Devices. Musst deshalb nicht die Platte abziehen. Aber mach wie Du denkst.

Nutzt Du UEFI oder BIOS? Bei Windows doch wahrscheinlich UEFI. Ist der Stick UEFI-fähig?


Also das ist wirklich wie verhext. Habe 2 usb sticks mit gparted partitioniert und als fat32 formatiert. Dann in windows mit dem "linux live usb" die iso drauf geschrieben. Auf beide sticks. So, dann heruntergefahren, im bootmenü hatte ich dann den stick in 2 varianten aufgelistet. Einmal als usb, einmal als uefi. Wenn ich usb auswähle passiert nix. Bei uefi kommt dann ne fehlermeldung "syslinux 4....no defaultbor UI configuration directive found".
Daraufhin die iso auf ne cd gebrannt. Dann kommt aber auch ne fehlermeldung "no bootldr" oder so ähnlich. Weiss echt nicht mehr weiter.
Bei linux mint 18 hat es noch wunderbar geklappt mit usb boot.......
Hat wer ne idee?
Danke :)
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Also das ist wirklich wie verhext. Habe 2 usb sticks mit gparted partitioniert und als fat32 formatiert. Dann in windows mit dem "linux live usb" die iso drauf geschrieben. Auf beide sticks. So, dann heruntergefahren, im bootmenü hatte ich dann den stick in 2 varianten aufgelistet. Einmal als usb, einmal als uefi. Wenn ich usb auswähle passiert nix. Bei uefi kommt dann ne fehlermeldung "syslinux 4....no defaultbor UI configuration directive found".
Daraufhin die iso auf ne cd gebrannt. Dann kommt aber auch ne fehlermeldung "no bootldr" oder so ähnlich. Weiss echt nicht mehr weiter.
Bei linux mint 18 hat es noch wunderbar geklappt mit usb boot.......
Hat wer ne idee?
Danke :)

Du hast für die Partition, von der Du booten willst, das Boot-Flag gesetzt?

Benutze doch bitte mal Unetbootin. Gibt es auch für Windows:

https://unetbootin.github.io/

Nur um auszuschließen, dass es schlicht an "linux live usb" liegt.
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Du hast für die Partition, von der Du booten willst, das Boot-Flag gesetzt?

Benutze doch bitte mal Unetbootin. Gibt es auch für Windows:

https://unetbootin.github.io/

Nur um auszuschließen, dass es schlicht an "linux live usb" liegt.


Ok werde das mal versuchen. Also mit gparted hab ich einfach nur dafür gesorgt, dass der stick aus einer einzigen fat32 partition besteht. Was ist die boot flag?
Mit live linux usb wird der stick ja dann bootfähig gemacht oder?
Bei der cd hab ich einfach in linux das brennprogramm banshee genommen und "abbild erstellen" gewählt.

Muss ich beim booten den stick als usb oder als uefi starten? Was ist das der unterschied?
Kann ich auch als alternative ubuntu 16.04 installieren (weil das damals geklappt hat) und dann auf 17.04 upgraden? Geht das?
Danke :)
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Ok werde das mal versuchen. Also mit gparted hab ich einfach nur dafür gesorgt, dass der stick aus einer einzigen fat32 partition besteht. Was ist die boot flag?
Mit live linux usb wird der stick ja dann bootfähig gemacht oder?
Bei der cd hab ich einfach in linux das brennprogramm banshee genommen und "abbild erstellen" gewählt.

Muss ich beim booten den stick als usb oder als uefi starten? Was ist das der unterschied?
Kann ich auch als alternative ubuntu 16.04 installieren (weil das damals geklappt hat) und dann auf 17.04 upgraden? Geht das?
Danke :)

Ich hab mal kurz geschaut, Dein Problem wird hier beschrieben:
https://wiki.ubuntuusers.de/Live-USB/#Probleme-beim-Boot-von-FAT32-Sticks

Das Boot-Flag zeigt an, dass die Partition bootbar ist. Kannst Du in GParted als "Markierung" setzen. UEFI ist der Nachfolger des normalen BIOS. Lies Dir mal bitte diesen Abschnitt durch:

https://de.wikipedia.org/wiki/Unified_Extensible_Firmware_Interface#Secure_Boot

Windows unterstützt nur Secure Boot und deshalb ist das bei Dir in den BIOS-Einstellungen wahrscheinlich voreingestellt. Ob Du trotzdem einen Nicht-UEFI-Bootvorgang (außer der Reihe sozusagen) durchführen kannst, hängt von Deinem Mainboard ab. Letztlich wirst Du es einfach ausprobieren müssen. Ich habe bei mir UEFI/Secure Boot immer komplett deaktiviert. Aber ich nutze auch kein Windows. Wenn Du es bei Dir komplett deaktivierst, startet danach Dein Windows nicht mehr. Daher für Dich keine Alternative. Linux unterstützt auch UEFI/Secure-Boot. Du musst das nutzen, wenn Du Windows und Linux auf demselben System betreiben möchtest.

Um von der 16.4. auf die 17.4. zu kommen musst Du über die 16.10. gehen:

16.4. ->16.10. -> 17.4.

Ein 17.4. Bootstick sollte eigentlich funktionieren. Zumindest sollte er mal booten. Ob dann das System sauber hochkommt, das ist nochmal eine andere Frage.
 
I

i-suffer-rock

Guest
Muss ich beim booten den stick als usb oder als uefi starten? Was ist das der unterschied?

Der Live-USB Stick ist so präpariert dass er sich auf zwei Arten booten lässt: entweder klassisch über den MBR (zur kompatibilität mit älteren PC die kein UEFI BIOS haben). Oder über UEFI (für aktuelle PCs).

Ich wähle immer UEFI wenn es geht. Ich habe bei mir auch Secure-Boot aktiviert mit den "strengsten" Sicherheitseinstellungen, ohne deswegen jemals Probleme mit Linux Live-USB Systemen gehabt zu haben.
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Danke erstmal für eure hilfe. Werde das heute alles ausprobieren :)
Noch ne frage bzw anmerkung, also einer meiner usb sticks ist ein u3 system. Wenn ich ihn anschliesse erscheint immer auch ein cd symbol in der datenträgertabelle. Soll ich diesen stick besser weglassen und einen normalen nehmen?
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Ich hab mal kurz geschaut, Dein Problem wird hier beschrieben:
https://wiki.ubuntuusers.de/Live-USB/#Probleme-beim-Boot-von-FAT32-Sticks

Das Boot-Flag zeigt an, dass die Partition bootbar ist. Kannst Du in GParted als "Markierung" setzen. UEFI ist der Nachfolger des normalen BIOS. Lies Dir mal bitte diesen Abschnitt durch:

https://de.wikipedia.org/wiki/Unified_Extensible_Firmware_Interface#Secure_Boot

Windows unterstützt nur Secure Boot und deshalb ist das bei Dir in den BIOS-Einstellungen wahrscheinlich voreingestellt. Ob Du trotzdem einen Nicht-UEFI-Bootvorgang (außer der Reihe sozusagen) durchführen kannst, hängt von Deinem Mainboard ab. Letztlich wirst Du es einfach ausprobieren müssen. Ich habe bei mir UEFI/Secure Boot immer komplett deaktiviert. Aber ich nutze auch kein Windows. Wenn Du es bei Dir komplett deaktivierst, startet danach Dein Windows nicht mehr. Daher für Dich keine Alternative. Linux unterstützt auch UEFI/Secure-Boot. Du musst das nutzen, wenn Du Windows und Linux auf demselben System betreiben möchtest.

Um von der 16.4. auf die 17.4. zu kommen musst Du über die 16.10. gehen:

16.4. ->16.10. -> 17.4.

Ein 17.4. Bootstick sollte eigentlich funktionieren. Zumindest sollte er mal booten. Ob dann das System sauber hochkommt, das ist nochmal eine andere Frage.


Danke erstmal an alle für die Tipps. Jetzt hat es endlich geklappt, konnte ubuntu installieren :)
Allerdings gibt es noch ein problem....aber der Reihe nach.
Also am ende hat es mit unetbootin funktioniert, aber es war alles andere als einfach. Habe zuerst den stick nochmal partitioniert und formatiert mit gparted und das häkchen bei "boot" gesetzt. Dann mit unetbootin ubuntu live drauf gespielt. Hatte dann aber einen blackscreen beim booten. Musste im grub menü auf der installation "e" drücken und dann den daraufhin erscheinenden text bearbeiten (nomodeset anstatt quiet splash). Leider muss ich das nun auch nach der instsllation machen, also jedes mal wo ich von ubuntu booten will. Also beim start die shift taste drücken, und im grub menü dann jedes mal diese prozedur. Noch schlimmer ist es jetzt wo ich auch die windows platte wieder angeschlossen habe. Komme jerzt nämlich mit shift gar nicht mehr ins grub menü uns somit lässt sich ubuntu gar nicht mehr booten. Komme zwar noch bis dahin wo man das passwort eingeben muss (wegen der verschlüsselung des systems) aber da reagiert weder die tastatur noch die maus, kann also nix eintippen. Wenn ich das pw trotzdem in die tastatur eintippe und mit enter bestätige passiert auch nix. Uns wie gesagt, ins grub komm ich auch nicht mehr......
Was kann man da noch machen?
Danke
 
I

i-suffer-rock

Guest
Probleme mit einem Verlust des Bildsignals (bzw. schwarzen Bildschirms) beim booten hatte ich in letzter Zeit auch auf einem Rechner mit Nvidia-Karte. Sehr komische Sache. Bei mir löste sich dieses Problem final erst mit dem Installieren des Nvidia Hersteller-Treibers (kann man ja in der Ubuntu Systemsteuerung einstellen).

Was das andere Problem angeht: Die zunächst einfachste Erlärung wäre wohl, dass Maus und Tastatur tatsächlich ausgeschaltet sind. Man müsste im UEFI BIOS einstellen können, welche USB-Geräte sofort beim starten des Systems (während des POST) schon aktiviert werden. Vielleicht hilft das ja.
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Also am ende hat es mit unetbootin funktioniert, aber es war alles andere als einfach. Habe zuerst den stick nochmal partitioniert und formatiert mit gparted und das häkchen bei "boot" gesetzt. Dann mit unetbootin ubuntu live drauf gespielt. Hatte dann aber einen blackscreen beim booten. Musste im grub menü auf der installation "e" drücken und dann den daraufhin erscheinenden text bearbeiten (nomodeset anstatt quiet splash). Leider muss ich das nun auch nach der instsllation machen, also jedes mal wo ich von ubuntu booten will. Also beim start die shift taste drücken, und im grub menü dann jedes mal diese prozedur.

Eigentlich sollte das nicht passieren. Es sollte eigentlich egal sein, ob man mit "quiet splash" bootet oder nicht. Du hast aber anscheinend ein Gegenbeispiel gefunden. Wenn sich das Problem tatsächlich dadurch löst, dann kannst Du das nach dem Booten natürlich dauerhaft in Grub eintragen. Lies Dir mal diesen Anschnitt durch:

https://wiki.ubuntuusers.de/Bootoptionen/#Dauerhafte-Konfiguration-eines-Systems

Hier ist meine komplette "/etc/default/grub":

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Das Entscheidende ist, dass Du die "GRUB_CMDLINE_LINUX_DEFAULT" (Zeile 11) auskommentierst, so wie ich es getan habe. Danach auf der Kommandozeile einfach folgendes aufrufen und warten bis der Grub seine Daten neu geschrieben hat:
Code:
sudo update-grub

Passwort musst Du noch eingeben. Auch die "/etc/default/grub" musst Du mit Root-Rechten öffnen. Kriegst Du das hin? Bin zu faul zum Erklären, wenn es nicht erforderlich ist. :B

Danach sollte Dein Rechner normal mit allen Meldungen ins Ubuntu booten.

Noch schlimmer ist es jetzt wo ich auch die windows platte wieder angeschlossen habe. Komme jerzt nämlich mit shift gar nicht mehr ins grub menü uns somit lässt sich ubuntu gar nicht mehr booten. Komme zwar noch bis dahin wo man das passwort eingeben muss (wegen der verschlüsselung des systems) aber da reagiert weder die tastatur noch die maus, kann also nix eintippen. Wenn ich das pw trotzdem in die tastatur eintippe und mit enter bestätige passiert auch nix. Uns wie gesagt, ins grub komm ich auch nicht mehr......
Was kann man da noch machen?
Danke

Moment mal, Du hast Ubuntu installiert während Du die Windowsplatte abgezogen hattest? Dann ist klar, dass er wieder ins Windows hinein bootet, sobald Du die wieder ansteckst. Was hast Du erwartet? Du musst die Platte schon angesteckt lassen, dann fragt Dich Ubuntu bei der Installation, was es damit machen soll und richten den GRUB entsprechend ein. Andernfalls musst Du das selbst machen, was nicht ganz trivial ist. Lass das lieber Ubuntu für Dich tun. Auch da hast Du keine Garantie, dass es danach funktioniert. Im schlimmsten Fall darfst Du danach Dein Windows neu installieren. Also vorher unbedingt Daten sichern. Ich kann leider nicht sagen wie gut der Ubuntu-Installer das macht, weil ich es nie ausprobiert habe (nutze kein Windows direkt auf der Hardware).


EDIT:
Und Du musst natürlich im BIOS die Platte, auf der sich Grub befindet, bei den Einstellungen zur Boot-Priority an erste Stelle bewegen.
 
Zuletzt bearbeitet:
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Eigentlich sollte das nicht passieren. Es sollte eigentlich egal sein, ob man mit "quiet splash" bootet oder nicht. Du hast aber anscheinend ein Gegenbeispiel gefunden. Wenn sich das Problem tatsächlich dadurch löst, dann kannst Du das nach dem Booten natürlich dauerhaft in Grub eintragen. Lies Dir mal diesen Anschnitt durch:

https://wiki.ubuntuusers.de/Bootoptionen/#Dauerhafte-Konfiguration-eines-Systems

Hier ist meine komplette "/etc/default/grub":

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Das Entscheidende ist, dass Du die "GRUB_CMDLINE_LINUX_DEFAULT" (Zeile 11) auskommentierst, so wie ich es getan habe. Danach auf der Kommandozeile einfach folgendes aufrufen und warten bis der Grub seine Daten neu geschrieben hat:
Code:
sudo update-grub

Passwort musst Du noch eingeben. Auch die "/etc/default/grub" musst Du mit Root-Rechten öffnen. Kriegst Du das hin? Bin zu faul zum Erklären, wenn es nicht erforderlich ist. :B

Danach sollte Dein Rechner normal mit allen Meldungen ins Ubuntu booten.



Moment mal, Du hast Ubuntu installiert während Du die Windowsplatte abgezogen hattest? Dann ist klar, dass er wieder ins Windows hinein bootet, sobald Du die wieder ansteckst. Was hast Du erwartet? Du musst die Platte schon angesteckt lassen, dann fragt Dich Ubuntu bei der Installation, was es damit machen soll und richten den GRUB entsprechend ein. Andernfalls musst Du das selbst machen, was nicht ganz trivial ist. Lass das lieber Ubuntu für Dich tun. Auch da hast Du keine Garantie, dass es danach funktioniert. Im schlimmsten Fall darfst Du danach Dein Windows neu installieren. Also vorher unbedingt Daten sichern. Ich kann leider nicht sagen wie gut der Ubuntu-Installer das macht, weil ich es nie ausprobiert habe (nutze kein Windows direkt auf der Hardware).


EDIT:
Und Du musst natürlich im BIOS die Platte, auf der sich Grub befindet, bei den Einstellungen zur Boot-Priority an erste Stelle bewegen.



Ok danke, hat jetzt funktioniert :)
Ich werde deine grub Einstellungen ausprobieren, hab erst mal einfach quiet splash mit nomodeset ersetzt, dauerhaft.
Wenn ich jetzt Ubuntu starte dann kommt halt anstatt des "graphischen" Menüs einfach n "Matrix -Text" wo man dann das PW eingeben kann. Passt.
Also liegt es wohl tatsächlich an den Grafiktreibern bzw an meiner Nvidia Grafikkarte.

Nee hab die Windowsplatte natürlich während der Ubuntu Installation abgesteckt ;)

Hab jetzt die Nvidia binary driver 375 ausgewählt, weiss nicht ob das jetzt was ändern würde wegen quiet splash.....
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Ok danke, hat jetzt funktioniert :)
Ich werde deine grub Einstellungen ausprobieren, hab erst mal einfach quiet splash mit nomodeset ersetzt, dauerhaft.

Brauchst Du nicht, denn die dürften auf Deinem System nahezu identisch sein.

Wenn ich jetzt Ubuntu starte dann kommt halt anstatt des "graphischen" Menüs einfach n "Matrix -Text" wo man dann das PW eingeben kann. Passt.
Also liegt es wohl tatsächlich an den Grafiktreibern bzw an meiner Nvidia Grafikkarte.

D.h. er bootet in die Konsole? Während des Bootvorgangs siehst Du verschiedene Meldungen. Text. Aber danach solltest Du natürlich in einem grafischen Login landen. Deine Karte (GTX 970) läuft unter Ubuntu einwandfrei. Ich besitze die gleiche.

Hab jetzt die Nvidia binary driver 375 ausgewählt, weiss nicht ob das jetzt was ändern würde wegen quiet splash.....

Ich weiß gerade nicht, welches Problem Du zu lösen versucht und was genau Du nun gemacht hast. Der "quiet splash" ist so überflüssig wie ein Kropf. Auf den kannst Du ruhig verzichten. Siehst Du denn den normalen Ubuntu-Desktop?

Den Nvidia-Treiber brauchst Du für die Spiele. Ohne Spiele tut es i.d.R. auch der vorinstallierte opensource Treiber.
 
Zuletzt bearbeitet:
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Brauchst Du nicht, denn die dürften auf Deinem System nahezu identisch sein.



D.h. er bootet in die Konsole? Während des Bootvorgangs siehst Du verschiedene Meldungen. Text. Aber danach solltest Du natürlich in einem grafischen Login landen. Deine Karte (GTX 970) läuft unter Ubuntu einwandfrei. Ich besitze die gleiche.



Ich weiß gerade nicht, welches Problem Du zu lösen versucht und was genau Du nun gemacht hast. Der "quiet splash" ist so überflüssig wie ein Kropf. Auf den kannst Du ruhig verzichten. Siehst Du denn den normalen Ubuntu-Desktop?

Den Nvidia-Treiber brauchst Du für die Spiele. Ohne Spiele tut es i.d.R. auch der vorinstallierte opensource Treiber.



Keine ahnung, also beim booten läuft jetzt ein weisser text auf schwarzem hintergrund. Ganz am ende muss ich das pw eingeben. Also das pw um die festplatte zu entschlüsseln, nicht das normale user login pw!
Danach startet ubuntu ganz normal.
Wenn ich den pc einschalte und nix mache bootet standartmässig windows 10. Also müsste doch alles passen ;)

Kann man eigentlich jetzt schon gnome installieren? Unity soll ja für die kommenden lts versionen nicht mehr weiterentwickelt werden........ist das ein "graphischer" rückschritt?
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Keine ahnung, also beim booten läuft jetzt ein weisser text auf schwarzem hintergrund. Ganz am ende muss ich das pw eingeben. Also das pw um die festplatte zu entschlüsseln, nicht das normale user login pw!
Danach startet ubuntu ganz normal.
Wenn ich den pc einschalte und nix mache bootet standartmässig windows 10. Also müsste doch alles passen ;)
Oh, Du hast wahrscheinlich Dein komplettes Heimatverzeichnis verschlüsselt. Das könnte der Grund für Deine Probleme gewesen sein. Das kann Dir auch noch an anderen Stellen auf die Füße fallen. Aber wenn es funktioniert, nutze es halt. Lass davon in Zukunft aber besser die Finger. Gibt Möglichkeiten mit deutlich weniger Seiteneffekten. Bei der Installation am besten nix verschlüsseln, außer Du weißt genau, was Du tust und warum. Leider bietet das Ubuntu recht prominent an ohne auf die Nebenwirkungen hinzuweisen.
Kann man eigentlich jetzt schon gnome installieren? Unity soll ja für die kommenden lts versionen nicht mehr weiterentwickelt werden........ist das ein "graphischer" rückschritt?
Natürlich kannst Du das nutzen. Auf der Konsole:
Code:
sudo apt-get install ubuntu-gnome-desktop
Kann man sich natürlich auch mit dem grafischen Softwaremanagement installieren. Danach einmal abmelden und mit dem Gnome-Desktop wieder anmelden. Da ist im Login-Manager eine Auswahlmöglichkeit. Ich glaube direkt bei der Anmeldemaske. Wenn es Dir nicht gefällt oder Du nicht damit klar kommst, wechselst Du halt wieder zurück oder probierst einen anderen Fenstermanager aus.

Ich selbst nutze derzeit kein Gnome. Aber natürlich ist das in Ubuntu schon immer enthalten. Ab nächsten Jahr wird es lediglich (wieder) der offizielle Standard-Desktop von Ubuntu.

Grafischer Rückschritt sicher nicht. Gnome3 ist einer der am weitesten entwickelten Linux-Desktops. Ist halt immer die Frage, ob man damit zurecht kommt. Ich werde es jedenfalls auch mal ausprobieren. Man muss sich auf jeden Desktop aber eben auch einlassen. Das ist individuell sehr verschieden. Sicherlich werden auch Leute Unity vermissen. Ich ganz sicher nicht. Fand Unity immer furchtbar. Ist aber letztlich Geschmackssache.
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Oh, Du hast wahrscheinlich Dein komplettes Heimatverzeichnis verschlüsselt. Das könnte der Grund für Deine Probleme gewesen sein. Das kann Dir auch noch an anderen Stellen auf die Füße fallen. Aber wenn es funktioniert, nutze es halt. Lass davon in Zukunft aber besser die Finger. Gibt Möglichkeiten mit deutlich weniger Seiteneffekten. Bei der Installation am besten nix verschlüsseln, außer Du weißt genau, was Du tust und warum. Leider bietet das Ubuntu recht prominent an ohne auf die Nebenwirkungen hinzuweisen.

Natürlich kannst Du das nutzen. Auf der Konsole:
Code:
sudo apt-get install ubuntu-gnome-desktop
Kann man sich natürlich auch mit dem grafischen Softwaremanagement installieren. Danach einmal abmelden und mit dem Gnome-Desktop wieder anmelden. Da ist im Login-Manager eine Auswahlmöglichkeit. Ich glaube direkt bei der Anmeldemaske. Wenn es Dir nicht gefällt oder Du nicht damit klar kommst, wechselst Du halt wieder zurück oder probierst einen anderen Fenstermanager aus.

Ich selbst nutze derzeit kein Gnome. Aber natürlich ist das in Ubuntu schon immer enthalten. Ab nächsten Jahr wird es lediglich (wieder) der offizielle Standard-Desktop von Ubuntu.

Grafischer Rückschritt sicher nicht. Gnome3 ist einer der am weitesten entwickelten Linux-Desktops. Ist halt immer die Frage, ob man damit zurecht kommt. Ich werde es jedenfalls auch mal ausprobieren. Man muss sich auf jeden Desktop aber eben auch einlassen. Das ist individuell sehr verschieden. Sicherlich werden auch Leute Unity vermissen. Ich ganz sicher nicht. Fand Unity immer furchtbar. Ist aber letztlich Geschmackssache.



Genau, hab bei der installation das häkchen bei festplatte verschlüsseln gemacht. Wusste net dass es da probleme geben kann. Aber jetzt funktioniert es ja. Ausserdem hatte ich ja schon vor und während der installation diese probleme mit stick und booten und so.....

Und welche wären diese möglichkeiten mit weniger seiteneffekten?

Ok dann werd ich das mal ausprobieren.
Sag mal was für distros kannst du mir denn so empfehlen? Hatte bisher nur mint und eben ubuntu. Wobei mint ganz ähnlich ist wie windows.
Deepin soll ja ganz toll sein.....
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Und welche wären diese möglichkeiten mit weniger seiteneffekten?

Einfach mit einem verschlüsselten Verzeichnis arbeiten, wo alles Schützenswerte drin landet. Macht man am besten auf der Konsole. Einfach dieser Anleitung folgen:

https://wiki.ubuntuusers.de/ecryptfs/Einrichten/

Braucht Du jetzt aber nicht. Der Punkt ist einfach: Beim Anmeldevorgang muss das System auf Dein Heimatverzeichnis zugreifen können bevor Du angemeldet bist. Entschlüsselt wird das Verzeichnis aber erst nach der Anmeldung. Das macht die Sache nicht gerade trivial, dafür aber störungsanfällig. Da es bei Dir jetzt aber läuft, lasse es erstmal so. Mach aber auf jeden Fall regelmäßig ein Backup Deiner Daten.

Sag mal was für distros kannst du mir denn so empfehlen? Hatte bisher nur mint und eben ubuntu. Wobei mint ganz ähnlich ist wie windows.
Deepin soll ja ganz toll sein.....

Ich würde an Deiner Stelle bei Ubuntu bleiben. Die ganzen Desktops bekommst Du auch für Ubuntu. Ubuntu basiert auf Debian. Das funktioniert Dank Canonical recht gut. Ubuntu gleicht das größte Problem von Debian aus: Die immer leicht veralteten Pakete. Auf dem Desktop ist das sehr angenehm.

Mint basiert wiederum auf Ubuntu. Die Kette Debian -> Ubuntu -> Mint führt leider immer wieder zu Problemen. Gerade bei der Hardwareerkennung und beim Support. Hinter Mint steht einfach kein Unternehmen, dass das vernünftig managt und auch die langweiligen Tasks erledigt, für die man typischerweise jemand bezahlen muss. Für Ubuntu bekommst Du sogar fix und fertig angepasste Systeme von DELL und anderen Herstellern. Da wird dann auch wirklich die gesamte Hardware unterstützt. Bei Laptops nicht unwichtig. Die LTS Version hat fünf Jahre Support. Der Wechsel zwischen den LTS-Versionen alle zwei Jahre ist i.d.R. sehr einfach. Ich warte meistens bis zum ersten Pointrelease, wenn ich auf dem LTS-Zweig bin.

Debian ist eine Alternative. Da Du dort im Desktopbetrieb allerdings auf Testing fahren musst, um so aktuelle Pakete wie in Ubuntu zu haben, ist das nur sehr erfahrenen Nutzern zu empfehlen. Debian ist aber trotzdem die solideste Linux-Distribution. Kommt sehr oft auf Servern zum Einsatz. Da stört zumeist die schon etwas ältere Software auch nicht. Für mich ist Debian im Desktopbereich eher so eine Versicherung. Sollte irgendwas mit Ubuntu oder Canonical passieren, kann ich dahin zurück.
 
TE
I

ImperialTW

Bekanntes Gesicht
Mitglied seit
18.10.2007
Beiträge
455
Reaktionspunkte
1
Einfach mit einem verschlüsselten Verzeichnis arbeiten, wo alles Schützenswerte drin landet. Macht man am besten auf der Konsole. Einfach dieser Anleitung folgen:

https://wiki.ubuntuusers.de/ecryptfs/Einrichten/

Braucht Du jetzt aber nicht. Der Punkt ist einfach: Beim Anmeldevorgang muss das System auf Dein Heimatverzeichnis zugreifen können bevor Du angemeldet bist. Entschlüsselt wird das Verzeichnis aber erst nach der Anmeldung. Das macht die Sache nicht gerade trivial, dafür aber störungsanfällig. Da es bei Dir jetzt aber läuft, lasse es erstmal so. Mach aber auf jeden Fall regelmäßig ein Backup Deiner Daten.



Ich würde an Deiner Stelle bei Ubuntu bleiben. Die ganzen Desktops bekommst Du auch für Ubuntu. Ubuntu basiert auf Debian. Das funktioniert Dank Canonical recht gut. Ubuntu gleicht das größte Problem von Debian aus: Die immer leicht veralteten Pakete. Auf dem Desktop ist das sehr angenehm.

Mint basiert wiederum auf Ubuntu. Die Kette Debian -> Ubuntu -> Mint führt leider immer wieder zu Problemen. Gerade bei der Hardwareerkennung und beim Support. Hinter Mint steht einfach kein Unternehmen, dass das vernünftig managt und auch die langweiligen Tasks erledigt, für die man typischerweise jemand bezahlen muss. Für Ubuntu bekommst Du sogar fix und fertig angepasste Systeme von DELL und anderen Herstellern. Da wird dann auch wirklich die gesamte Hardware unterstützt. Bei Laptops nicht unwichtig. Die LTS Version hat fünf Jahre Support. Der Wechsel zwischen den LTS-Versionen alle zwei Jahre ist i.d.R. sehr einfach. Ich warte meistens bis zum ersten Pointrelease, wenn ich auf dem LTS-Zweig bin.

Debian ist eine Alternative. Da Du dort im Desktopbetrieb allerdings auf Testing fahren musst, um so aktuelle Pakete wie in Ubuntu zu haben, ist das nur sehr erfahrenen Nutzern zu empfehlen. Debian ist aber trotzdem die solideste Linux-Distribution. Kommt sehr oft auf Servern zum Einsatz. Da stört zumeist die schon etwas ältere Software auch nicht. Für mich ist Debian im Desktopbereich eher so eine Versicherung. Sollte irgendwas mit Ubuntu oder Canonical passieren, kann ich dahin zurück.


Ok danke für die tipps, war echt hilfreich :)
Hab noch 2 letzte fragen:

Wie kann ich in ubuntu andere desktops installieren? Kann ich beispielsweise den deepin desktop eimrichten?
Finde den "starter" von ubuntu so unübersichtlich, kann man den irgendwie bearbeiten?

Wie sieht es eigentlich bei ubuntu in sachen datenschutz aus? Weil hier ja, wie du sagst, ein konzern dahinter steht. Linux mint zum beispiel wird ja von einer "community" gepflegt und ich finde da gab es auch ständig updates....

Denn ich hab schon noch windows, aber nur zum gelegentlichen zocken oder für microsoft office. Aber ansonsten hat mich windows total abgeschreckt, so wie hier daten regelrecht geklaut werden ist einfach ne frechheit und sollte eigentlich illegal sein!!
 

1xok

Bekanntes Gesicht
Mitglied seit
05.06.2016
Beiträge
1.205
Reaktionspunkte
390
Ok danke für die tipps, war echt hilfreich :)
Hab noch 2 letzte fragen:

Wie kann ich in ubuntu andere desktops installieren? Kann ich beispielsweise den deepin desktop eimrichten?

Am einfachsten über die Konsole. Der Deepin Desktop ist nicht im Standardsystem enthalten, lässt sich aber wohl über das Launchpad nachinstallieren:

https://askubuntu.com/questions/761107/how-to-install-deepin-desktop-environment-in-ubuntu-16-04-lts

Vorsicht, nicht getestet:

sudo add-apt-repository ppa:leaeasy/dde
sudo apt-get update
sudo apt-get install dde
Der erste Befehl erweitert Dein Paketsystem um das DDE-Resository
Der zweite Befehl updatet Dein Paketsystem, damit die Erweiterung wirksam wird.
Der dritte Befehl schließlich installiert DDE.
Finde den "starter" von ubuntu so unübersichtlich, kann man den irgendwie bearbeiten?

Ja, aber die Mühe lohnt meiner Meinung nach nicht. Unity ist einer der am schlechtesten konfigurierbaren Desktops, den ich kenne. Alles ist dort, wo man es am wenigsten vermutet. Tue Dir den Gefallen und meide Unity. Canonical hat Unity ja selbst aufs Abstellgleis geschoben. Es gibt Leute, die mögen Unity und kommen damit klar. Aber ich kenne ehrlich gesagt nur sehr wenige. Nutze Xfce oder einen Desktop Deiner Wahl. Xfce ist sehr einfach zu verändern. Sehr übersichtlich gestaltet.

Wie sieht es eigentlich bei ubuntu in sachen datenschutz aus? Weil hier ja, wie du sagst, ein konzern dahinter steht. Linux mint zum beispiel wird ja von einer "community" gepflegt und ich finde da gab es auch ständig updates....

Na Konzern ist etwas übertrieben. Allerdings geht Canonical jetzt an die Börse. Du musst Dir da aber keine Sorgen machen. Es ist ein quelloffenes System mit sehr weniger proprietärer Software. Canonical kann da nicht einfach irgendwelche Daten übertragen ohne dass es die Community bemerkt. Deine Privatsphäre ist vor allem durch Anwendungen gefährdet, vor allem durch Browser wie Google Chome. Hier hast Du mit Chromium eine sehr gute Alternative. Das ist der Google Chrome Browser ohne Schnüffelei. Hat die Community raus gepatcht mit freundlicher Unterstützung von Google, die ihren Chrome ja komplett als OpenSource vertreiben. Chromium ist sehr gut in Ubuntu integriert.

Ubuntu schickt keinerlei Daten irgendwohin. Nur zur Fehleranalyse, wenn ein Programm abgestürzt ist. Und dann bekommst Du das ausführlich mitgeteilt und kannst dem natürlich widersprechen oder es auch ganz abstellen.

Canonical arbeitet in den wichtigen Kernbereichen sehr professionell. Bei Mint kann es Dir auch mal passieren, dass Hacker das Installation-Image auf den Mint -Server austauschen. Nichts gegen Mint. Sie haben tolles geleistet. Aber letztlich ist es einfach eine Reaktion der Community auf den merkwürdigen Unity-Desktop und die Alleingänge des Gnome-Projektes gewesen. Das Problem von Ubuntu ist bis heute der Unity Desktop. Den kann man zwar sehr einfach austauschen, aber er erschüttert am Anfang einfach das Vertrauen in das System. Wer will ein System benutzen, dass einen mit einem derart merkwürdigen und teilweise schlicht dysfunktionalen Desktop begrüßt? Der erste Eindruck ist der wichtigste und der ist bei Ubuntu leider ein schlechter. Mir tut das richtig weh, weil das System darunter ist grundsolide und hat fantastische Eigenschaften.

Ich will Dich nicht abhalten, wenn Du auf Mint umschwenken möchtest. Aber versuche Ubuntu einfach mal mit einem gescheiten Desktop zu benutzen. Ich kann Xubuntu sehr empfehlen. Hier eine Übersicht:

https://wiki.ubuntuusers.de/Desktop/

Mate, Gnome, KDE, hast Du alles schon in den Standardpaketquellen.

Xubuntu installierst Du einfach über:
sudo apt-get install xubuntu-desktop

An die anderen Desktops kommst Du genauso einfach.

Das ist echt alles. Wenn Du willst, kann ich das auch mal auf meinem Twitch-Kanal vorstellen.

Denn ich hab schon noch windows, aber nur zum gelegentlichen zocken oder für microsoft office. Aber ansonsten hat mich windows total abgeschreckt, so wie hier daten regelrecht geklaut werden ist einfach ne frechheit und sollte eigentlich illegal sein!!

Da musst Du Dir keine Sorgen machen. Sowas gibt es unter Ubuntu nicht. Du segnest an keiner Stelle eine EULA oder etwas Vergleichbares ab. Im übrigen basiert Mint auch auf Ubuntu. Natürlich muss man das immer weiter beobachten. Canonical könnte ja irgendwann einmal böse werden. Bisher sehe ich dafür aber keine Anzeichen. Canonical hat sich bis jetzt immer sehr fair und nachvollziehbar verhalten.
 
Oben Unten