7800gs g71 unter win98 (oder alternativen?)

R

ruyven_macaran

Guest
moin,
nächste woche werde ich hoffentlich mal zeit für "format c:" finden und dann muss ich auch endlich mal ein 7 monate altes problem lösen:

es gibt keinen passenden treiber für meine grafikkarte.
die letzte win9x forceware (81.98) erschien 2monate vor erscheinen der 7800gs und hat keinen passenden eintrag.
interessanterweise lief sie mit meiner ersten 7800gs zumindest für kurze tests problemlos (hab 6800ultra bei der installation angewählt), mit meiner neuen klappt der trick aber nicht mehr.
vermutung: liegt am neueren g71 chip, der g70 war nämlich zu 81.98 zeiten schon am markt. (wenn auch nur für pci-e und auch da ohne eintrag in der win9x forceware - aber es ist wohl davon auszugehen, dass nvidia die treiber nicht komplett einzeln für beide betriebssysteme entwickelt)


wie dem auch sei:
ich bräuchte jetzt jedenfalls einen g71/7800gs tauglichen treiber, der unter windows98se läuft und weder nvidia noch XFX unterstützen sowas offiziell.

weiß jemand eine lösung?

(z.b. ob man irgendwie die nötigen abschnitte aus neueren winXP forcewares übertragen kann? oder kann man von linuxtreibern ausgehend was machen?)


p.s.:
weiß jemand, ob es für ne x1950pro agp win9x treiber gibt?


p.p.s.:
wer software-alternativen/emulatoren vorschlagen will:
das co-kriterium sind win95/98 3d spiele wie dethkarz, N.I.C.E., Alice,... die unter winXP nicht laufen - und die i.d.r. zu hohe hardwareanforderungen für emulationen haben. (echte virtualisierungen laufen bei mir gar nicht, cpu hat kein vanderpool/pacifica, außerdem bräuchte ich dann eh wieder nen treiber)

linux wäre noch eine option, allerdings kommen dann als zusätzliche hürde hochkarätige dos-titel wie privateer2 hinzu, die ich nur mit mühe und not überhaupt unter 9x zum laufen bringen konnte. (hauptproblem: audigy2zs bzw. pci karten allgemein, einzig mir bekannte lösung ist die sb16 emulation der audigy1)
 

ShiZon

Bekanntes Gesicht
Mitglied seit
21.12.2006
Beiträge
2.271
Reaktionspunkte
0
ruyven_macaran am 10.02.2007 23:57 schrieb:
moin,
nächste woche werde ich hoffentlich mal zeit für "format c:" finden und dann muss ich auch endlich mal ein 7 monate altes problem lösen:

es gibt keinen passenden treiber für meine grafikkarte.
die letzte win9x forceware (81.98) erschien 2monate vor erscheinen der 7800gs und hat keinen passenden eintrag.
interessanterweise lief sie mit meiner ersten 7800gs zumindest für kurze tests problemlos (hab 6800ultra bei der installation angewählt), mit meiner neuen klappt der trick aber nicht mehr.
vermutung: liegt am neueren g71 chip, der g70 war nämlich zu 81.98 zeiten schon am markt. (wenn auch nur für pci-e und auch da ohne eintrag in der win9x forceware - aber es ist wohl davon auszugehen, dass nvidia die treiber nicht komplett einzeln für beide betriebssysteme entwickelt)


wie dem auch sei:
ich bräuchte jetzt jedenfalls einen g71/7800gs tauglichen treiber, der unter windows98se läuft und weder nvidia noch XFX unterstützen sowas offiziell.

weiß jemand eine lösung?

(z.b. ob man irgendwie die nötigen abschnitte aus neueren winXP forcewares übertragen kann? oder kann man von linuxtreibern ausgehend was machen?)


p.s.:
weiß jemand, ob es für ne x1950pro agp win9x treiber gibt?


p.p.s.:
wer software-alternativen/emulatoren vorschlagen will:
das co-kriterium sind win95/98 3d spiele wie dethkarz, N.I.C.E., Alice,... die unter winXP nicht laufen - und die i.d.r. zu hohe hardwareanforderungen für emulationen haben. (echte virtualisierungen laufen bei mir gar nicht, cpu hat kein vanderpool/pacifica, außerdem bräuchte ich dann eh wieder nen treiber)

linux wäre noch eine option, allerdings kommen dann als zusätzliche hürde hochkarätige dos-titel wie privateer2 hinzu, die ich nur mit mühe und not überhaupt unter 9x zum laufen bringen konnte. (hauptproblem: audigy2zs bzw. pci karten allgemein, einzig mir bekannte lösung ist die sb16 emulation der audigy1)

Ich weiß nicht, ob das was bringt, gibt es für Win 98 SE noch ein Update von Microsoft und dann ggf. den Win 98 SE Standard-Graka Treiber nutzen? :-o

Einen Rechner mit XP hast du nicht zufällig? :-o Hast du es auch schon mal mit dem Hersteller-Treiber deiner Graka versucht? :)
 
TE
R

ruyven_macaran

Guest
ShiZon am 11.02.2007 13:37 schrieb:
Ich weiß nicht, ob das was bringt, gibt es für Win 98 SE noch ein Update von Microsoft und dann ggf. den Win 98 SE Standard-Graka Treiber nutzen? :-o

wüsste nicht, dass es updates für den standardtreiber gibt - selbst wenn werden die kein 1600x1200 oder 3d funktionen unterstützen.

Einen Rechner mit XP hast du nicht zufällig?

der gleiche rechner hat xp als primäres os, aber da läuft halt einiges nicht mit.

:-o Hast du es auch schon mal mit dem Hersteller-Treiber deiner Graka versucht? :)

gibt keinen herstellertreiber für win9x ;)
(genaugenommen gibt es von xfx überhaupt keine in irgend einer weise veränderten herstellertreiber)
 
TE
R

ruyven_macaran

Guest
kleines update:
hab sie gestern mal kurz als quaddro4000 gestartet bekommen, konnte sogar die auflösung ändern, aber der neustart für ne höhere farbtiefe hat nicht geklappt, seitdem komm ich auch nicht mehr an die einstellungen ran :(

niemand hier ahnung von 9x treibern?
 

ShiZon

Bekanntes Gesicht
Mitglied seit
21.12.2006
Beiträge
2.271
Reaktionspunkte
0
ruyven_macaran am 13.02.2007 17:57 schrieb:
kleines update:
hab sie gestern mal kurz als quaddro4000 gestartet bekommen, konnte sogar die auflösung ändern, aber der neustart für ne höhere farbtiefe hat nicht geklappt, seitdem komm ich auch nicht mehr an die einstellungen ran :(

niemand hier ahnung von 9x treibern?

CD's mit Treibern von PC-Magazinen hast du nicht zufällig? :-o Weißt du zufällig ob per imageshack oder einem anderen Programm Treiber hochgeladen werden können? Ich habe nämlich eine Menge Treiber, auch für ältere Grakas! :)

Schau mal, was ich feines gefunden habe, vielleicht hilft dir das? :-D

http://www.chip.de/downloads/c1_downloads_13000389.html
 

d00mfreak

Bekanntes Gesicht
Mitglied seit
09.03.2005
Beiträge
882
Reaktionspunkte
9
Versuch mal, den neuesten G71/G70 Treiber für Win9X zu verwenden, und die PID und VID Einträgein der inf-Datei auf deine GraKa anzupassen.
 
TE
R

ruyven_macaran

Guest
d00mfreak am 13.02.2007 19:15 schrieb:
Versuch mal, den neuesten G71/G70 Treiber für Win9X zu verwenden, und die PID und VID Einträgein der inf-Datei auf deine GraKa anzupassen.

wo mach ich das und wie lauten die richtigen einträge? (sorry, noob ;) )


@shizon:
bei bedarf könntest du mir auch mailen, aber mein problem sind nicht treiber für eine alte grafikkarte - sondern welche für eine neue ;) (in kombination mit einem alten os)
der treiber aus dem link z.b. ist n 77.xx, ich hab hier nen 81.xx der zu alt ist.
 

d00mfreak

Bekanntes Gesicht
Mitglied seit
09.03.2005
Beiträge
882
Reaktionspunkte
9
ruyven_macaran am 13.02.2007 22:20 schrieb:
d00mfreak am 13.02.2007 19:15 schrieb:
Versuch mal, den neuesten G71/G70 Treiber für Win9X zu verwenden, und die PID und VID Einträgein der inf-Datei auf deine GraKa anzupassen.

wo mach ich das und wie lauten die richtigen einträge? (sorry, noob ;) )


@shizon:
bei bedarf könntest du mir auch mailen, aber mein problem sind nicht treiber für eine alte grafikkarte - sondern welche für eine neue ;) (in kombination mit einem alten os)
der treiber aus dem link z.b. ist n 77.xx, ich hab hier nen 81.xx der zu alt ist.

Nimm mal den Standart-XP Treiber, und versuch ihn zu installieren. Sobald es nach dem Entpackvorgang abbricht, öffnest du den Gerätemanager, wählst deine GraKa aus, und klickst auf "Treiber aktualisieren", und danach "Auf dem Computer nach Treiber suchen" oder so ähnlich. In diesem Dialog navigierst du zum Ort, wo die Treiber hinentpackt wurden (Standartmäßig C:\Nvidia\xxxxx) und klickst auf weiter. Ab da an heißt es hoffen, dass windows was findet
 
TE
R

ruyven_macaran

Guest
d00mfreak am 13.02.2007 23:15 schrieb:
Nimm mal den Standart-XP Treiber, und versuch ihn zu installieren. Sobald es nach dem Entpackvorgang abbricht, öffnest du den Gerätemanager, wählst deine GraKa aus, und klickst auf "Treiber aktualisieren", und danach "Auf dem Computer nach Treiber suchen" oder so ähnlich. In diesem Dialog navigierst du zum Ort, wo die Treiber hinentpackt wurden (Standartmäßig C:\Nvidia\xxxxx) und klickst auf weiter. Ab da an heißt es hoffen, dass windows was findet

hat leider nicht funktioniert - zwar ist die info datei scheinbar immer noch die gleiche, aber es werden "keine hardwareinformationen gefunden"
scheinbar hat m$ n bissl das treiberformat geändert..

noch ne idee?

edit: und einer ne idee, wie man ohne abgesicherten modus nen nicht funktionierenden treiber wieder entfernt?
 

d00mfreak

Bekanntes Gesicht
Mitglied seit
09.03.2005
Beiträge
882
Reaktionspunkte
9
Ok, dann versuchen wir noch was anderes: Du schnappst die die neueste Forceware, die es für Win 98 gibt (sollte wenigstens den G70 unterstützen, ansonsten schaut`s düster aus). Dann entpackst du ihn, wie ich es oben gesagt habe.
Danach öffnest du die Datei nv4_disp.inf (oder nv_disp.inf k. Ahnung, wie die bei dir genau heißt).
Hier scrollst du zu der Zeile "[NVIDIA.Mfg]" (ohne Anführungszeichen, im Folgenden auch immer). Darunter fügst du dann die Zeile "%NVIDIA_BR02.DEV_00F5.1% = nv_NV3x, PCI\VEN_10DE&DEV_00F5" ein.

Danach scrollst du zur Zeile "; Localizable Strings" und fügst darunter die
Zeile "NVIDIA_BR02.DEV_00F5.1 = "NVIDIA GeForce 7800 GS"" ein.

Ganz oben müsste eine Zeile sein, die den Namen "ClassGUID" trägt.
Die nachfolgende Nummer ersetzt du mit der Nummer, die du im Gerätemgr. -> Rechtsklick auf die Graka (7800GS) -> das Register "Details", dann im Fenster "Geräteklasse-GUID" findest.
Die geänderte inf speicherst du dann und kopierst sie in einen entpackten XP Treiber. Falls sie hier anders heißt, musst du gegebenfalls noch den Namen anpassen
Und wenn das jetzt auch nicht funzt, dann bin ich mit meinem Latein am Ende.
Falls du was nicht verstehst, meld´ dich per O-Mail
;)
 
TE
R

ruyven_macaran

Guest
d00mfreak am 18.02.2007 20:50 schrieb:
Ok, dann versuchen wir noch was anderes: Du schnappst die die neueste Forceware, die es für Win 98 gibt (sollte wenigstens den G70 unterstützen, ansonsten schaut`s düster aus).

offiziell nicht, aber die g70 7800gs lief damit. (als 6800ultra)

Dann entpackst du ihn, wie ich es oben gesagt habe.
Danach öffnest du die Datei nv4_disp.inf (oder nv_disp.inf k. Ahnung, wie die bei dir genau heißt).

nvagp.inf
klingt komisch, ist aber so.

Hier scrollst du zu der Zeile "[NVIDIA.Mfg]" (ohne Anführungszeichen, im Folgenden auch immer). Darunter fügst du dann die Zeile "%NVIDIA_BR02.DEV_00F5.1% = nv_NV3x, PCI\VEN_10DE&DEV_00F5" ein.
[/quote]

eingefügt (und [mfg] )

Danach scrollst du zur Zeile "; Localizable Strings" und fügst darunter die
Zeile "NVIDIA_BR02.DEV_00F5.1 = "NVIDIA GeForce 7800 GS"" ein.

[strings], done

Ganz oben müsste eine Zeile sein, die den Namen "ClassGUID" trägt.
Die nachfolgende Nummer ersetzt du mit der Nummer, die du im Gerätemgr. -> Rechtsklick auf die Graka (7800GS) -> das Register "Details", dann im Fenster "Geräteklasse-GUID" findest.

werd ich unter 98 gucken müssen, unter xp gibts den eintrag auch nicht.
(in der 9x treiberdatei auch nicht, aber das lässt sich ja ändern)

Die geänderte inf speicherst du dann und kopierst sie in einen entpackten XP Treiber. Falls sie hier anders heißt, musst du gegebenfalls noch den Namen anpassen
Und wenn das jetzt auch nicht funzt, dann bin ich mit meinem Latein am Ende.
Falls du was nicht verstehst, meld´ dich per O-Mail
;)


meld mich, wenn ich ergebnisse habe.

(jetzt muss erstmal ram raus, damit ich überhaupt in den abgesicherten komme)



edit: konnte wieder keine guid finden, irgendwie hab ich keinen "details" reiter.

egal. akzeptiert wurde der modifizierte treiber trotzdem, aber das resultierende bild blieb "bunt gestreift".
auch ein versuch mit ner neueren forceware ausgabe und umfangreicheren modifikationen brachte nichts :(

hat vielleicht sonst noch jemand ne idee?

kann man vielleicht irgendwas mit linux treibern rumpfuschen?
n treiber, der sich in verschiedene kernel kompilieren lässt, muss ja in ner relativ rohen form forliegen - könnte man sowas nicht in eine windows kompatible form bringen?
*eigentlich keine ahnung von linux hab*
 
Oben Unten