Vista x64 DWM crasht nach Spielen

nd1312

Neuer Benutzer
Mitglied seit
02.11.2003
Beiträge
12
Reaktionspunkte
0
Hi, hab seit einigen Tagen nen neuen PC mit Vista x64.

Nur habe ich leider das Problem, dass sich jedes mal wenn ich ein Spiel beende der Windows display manager (dwm.exe) mit der Meldung "Desktop Window Manger stopped working....." verabschiedet.

Was zur Folge hat, dass ich dann kein Aero mehr habe.

Nun hab ich schon einige zeit recherchiert und gelesen, dass Windows bei Vollbild 3D Applikation dwm stoppt und danach wieder startet.
Nur scheint er bei mir beim wieder starten Probleme zu haben.

Hier mal die entsprechenden Meldungen aus den Event Logs:
[info] - A request to disable the Desktop Window Manager was made by process (Guild Wars Game Client)
[info] - The Desktop Window Manager was unable to start because composition was disabled by a running application
[Error] - Faulting application Dwm.exe, version 6.0.6001.18000, time stamp 0x4791944e, faulting module milcore.dll, version 6.0.6001.18000, time stamp 0x4791ad23, exception code 0xc0000094, fault offset 0x000000000006157c, process id 0x134, application start time 0x01c8f279adcb94b9.

Habe zb auch herausgefunden, dass man mit den befehlen
net stop uxsms und
net start uxsms
den dwm oder aero(?) manuell starten und stoppen kann.
Das funktioniert bei mir auch, außer wenn dwm gecrasht ist, dann kann ich zwar "stop" ausführen, aber bei "start" kommt wieder "...stopped working..." mit dem selben Event Log error.

Weiters sehr seltsam sind die angaben in den Display Settings nach einem solchen Absturz.
Und zwar sagt mir Vista dass ich 640x480 mit 8bit eingestellt hätte (was natürlich Quatsch ist).
Noch spannender sind die Angaben im Catalyst Control Center, dort steht zwar richtig 1920x1200 aber eine refresh rate von 142538432i Hz :B

Zu meinem System:

Mainboard: Asus P5QL-E
Grafikkarte: Sapphire HD4870
Prozessor: Intel Core 2 Quad Q9450
Ram: 4gb OCZ 1066
Monitor: HP w2408 24" 1920x1200 native

Catalyst hab ich schon von 8.6 auf 8.7 upgedated aber kein Unterschied.

Vielleicht kennt ja jemand das Problem und hat eventuell eine Lösung parat.
Danke im Vorraus!
 
TE
N

nd1312

Neuer Benutzer
Mitglied seit
02.11.2003
Beiträge
12
Reaktionspunkte
0
So bin dem Problem jetzt selbst auf den grund gekommen.

Und zwar war der Fehler die Option "Reduce DVI frequency on high-resolution displays" im Catalyst control center.

Ich hatte sie aktiviert weil ich in Guild Wars Anzeigefehler hatte auf 1920x1200 mit 4x FSAA.
Ich dachte dass ich diesen Fehler bei anderen Spielen auch hab ( ich sah nur die hälfte des Bildschirms in extrem schlechter Qualität) aber er tritt tatsächlich nur in GW auf wenn die Option deaktivirt ist und ich auf 1920x1200 spiele. Mit 1920x1080 funktionierts, und das ist zu verkraften :-D
 
Oben Unten