1. #1
    Neuer Benutzer
    Avatar von Daniel1974
    Registriert seit
    06.09.2003
    Ort
    Hatten
    Beiträge
    2

    Age of Empires 2 - Spielteilnahme nicht möglich

    Hallo Leute.

    Ich bin ja eigentlich ein alter Hase was Software und Hardware und das Lösen von Problemen angeht.
    Aber diesmal komme selbst ich nicht weiter.

    Meine Lebensgefährtin und ich spielen ja gelegentlich eine Runde "Age of Empires 2" zusammen.
    Sie hat Windows XP Professional und ich Windows Vista Ultimate 64 Bit.
    Das hat bis dato alles prima funktioniert.
    Wir haben beide eine Originalversion und die CD liegt im Laufwerk.
    Es ist der letzte verfügbare Patch aufgespielt.
    Gespielt wurde über eine Kabelverbindung.

    Dann zickte letztens der Linksys-Router rum.
    Ich schaffte mir einen neuen Linksys-Router an - WAG160N.
    DHCP und WLAN ist deaktiviert.
    Portforwarding ist aktiviert.
    Im alten Router waren keine besonderen weiteren Einstellungen gemacht worden, im Neuen also auch nicht.

    Gemäß Vista wurde der Netzwerkassistent erneut durchgeführt.
    Es sind feste IP-Adressen vergeben.

    Jetzt funktioniert das Spielen von "Age of Empires 2" im Netzwerk nicht mehr. Andere Spiele wie Counterstrike funktionieren.
    Ich sehe ja auch das meine Lebensgefärtin ein Spiel gestartet hat und sehe den Namen.
    Beim Versuch mit diesem zu verbinden passiert 15 sec gar nichts. Dann kommt die Meldung "Verbindung zum Spiel nicht möglich."

    Ich hatte auch schon den Windows Firewall-Eintrag für "Age of Empires 2" gelöscht und neu eintragen lassen.
    Das braucht er ja sowieso, wenn der Netzwerkassistent gestartet wird.

    Unter Windows XP in der Firewall gibt es noch einen Eintrag für DirectPlay (DPlaysvr.exe). Diesen gibt es unter Vista nicht.
    Liegt es vielleicht daran?
    Gibt es DirectPlay denn noch unter Vista?

    Mir sind sonst die Ideen ausgegangen.....

    •   Alt

      Anzeige
      Bitte einloggen, um diese Anzeige auszublenden.
       

  2. #2
    Community Officer
    Avatar von Herbboy
    Registriert seit
    22.03.2001
    Beiträge
    55.999

    AW: Age of Empires 2 - Spielteilnahme nicht möglich

    - versuch es mal mit DHCP an, dann verwaltet der router alles - gibt an sich doch eh keinen grund für feste IPs ^^

    - was ist, wenn DU das spiel hostest?

    - muss man vlt. im router ebenfalls was an dessen firewall freigeben? ports öffnen?
    This is not what I have wanted - I have to leave this place
    This is not what I have dreamed of - I need to gain more space

  3. #3
    Erfahrener Benutzer
    Avatar von NOODLES_SOS
    Registriert seit
    22.03.2001
    Beiträge
    399

    AW: Age of Empires 2 - Spielteilnahme nicht möglich

    Zitat Zitat von Herbboy Beitrag anzeigen
    - muss man vlt. im router ebenfalls was an dessen firewall freigeben? ports öffnen?
    - IPX zu nehmen scheidet mit Vista 64 aus.

    - Teste ob es ohne Internet funktioniert, einfach das Kabel abziehen.

    - Nimm ein reines Switch, keinen Router, wenn vorhanden.

    Spätestens das letzte hat bei uns immer funktioniert, welche Einstellung am Router da Probleme macht haben wir nie herausgefunden.
    Wille und C4 können Berge versetzen.

  4. #4
    Neuer Benutzer
    Themenstarter
    Avatar von Daniel1974
    Registriert seit
    06.09.2003
    Ort
    Hatten
    Beiträge
    2

    AW: Age of Empires 2 - Spielteilnahme nicht möglich

    Alles falsch.

    Es hat ja vorher auch funktioniert!

    Ich habe aber die Lösung gefunden, nach der wohl viele "Age of Empires 2"-Spieler suchen werden/gesucht haben!
    Etliche Foren sind voll mit dem obigen Problem.

    Das Problem heißt UPnP!

    Man muss UPnP zuerst unter Vista deaktivieren.
    Unter Windows XP kann man es wohl nicht abschalten, jedenfalls habe ich nichts derartiges gefunden.
    Man muss den WinXP-PC solange vom Router/Switch rausnehmen - Stecker ziehen.
    Dann im Router/Modem UPnP deaktivieren.
    Router/Modem neustarten, besser für 5 min stromlos machen und erneut kontrollieren ob UPnP wirklich deaktiviert wurde.
    Bei meinem Linksys WAG160N hat sich UPnP nämlich wieder aktiviert, weil WinXP mit laufendem UPnP noch dranhing.
    Erst nach rausnehmen des WinXP PC ging es.
    Jetzt können wir wieder AoE2 im LAN spielen.

    Ist natürlich für die Leute von Nachteil, die voll auf die Vereinfachung durch UPnP setzen.
    Dann muss man sich entscheiden.

    Noch ein Wort zu DHCP.
    In jedem kleineren Netzwerk macht DHCP für mich keinen Sinn und ist bei einem verwendeten WLAN der erste Schritt "in" ein Funknetzwerk. Durch DHCP bekommt erstmal jeder anfragende Rechner eine IP zugewiesen.
    Wenn ich ein Heimnetzwerk einrichte, ist meine erst Maßnahme: DHCP deaktivieren.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  

Anmelden

Anmelden